Discussion:
voorwaardelijke opmaak: plaatsen van "/"
(te oud om op te antwoorden)
Frédéric
2005-01-06 20:31:03 UTC
Permalink
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Ad Bécude
2005-01-06 21:15:05 UTC
Permalink
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")

In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.

Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Frédéric
2005-01-06 21:29:07 UTC
Permalink
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
geen tekst meer intikken in die bewuste cellen, en daar gaat het nu net om:
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Ad Bécude
2005-01-06 21:55:07 UTC
Permalink
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /""zet hier je tekst";"")
Probeer hier eens iets mee.
Ad.
Post by Frédéric
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Frédéric
2005-01-06 22:29:03 UTC
Permalink
je formule werkt zeker, Ad, maar indien ik na het invoegen van deze formule
toch nog iets wil schrijven in die bewuste cel, dan overschrijf ik steeds de
formule, waardoor ik dus slechts 1x de juiste opmaak bekom en na het
overschrijven de opmaak dus verlies, tenzij ik de formule dus steeds opnieuw
invoeg, wat echter een onbegonnen werk is.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /""zet hier je tekst";"")
Probeer hier eens iets mee.
Ad.
Post by Frédéric
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Ad Bécude
2005-01-06 22:45:11 UTC
Permalink
Frédéric,
Als je "zet hier je tekst selecteerd", kun je dat stukje overschrijven, de
rest blijft staan.
Het is geen super oplossing, maar toch.
Misschien weet iemand wel iets met een macro?

Ad.
Post by Frédéric
je formule werkt zeker, Ad, maar indien ik na het invoegen van deze formule
toch nog iets wil schrijven in die bewuste cel, dan overschrijf ik steeds de
formule, waardoor ik dus slechts 1x de juiste opmaak bekom en na het
overschrijven de opmaak dus verlies, tenzij ik de formule dus steeds opnieuw
invoeg, wat echter een onbegonnen werk is.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /""zet hier je tekst";"")
Probeer hier eens iets mee.
Ad.
Post by Frédéric
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Ad Bécude
2005-01-06 23:14:54 UTC
Permalink
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /"&"zet hier je tekst";"")
Deze gaat beter, als je op de cel dubbelklikt en je selecteerd "zet hier je
tekst"
kun je die gewoon wijzigen, de formule blijft heel.
Het is geen perfecte oplossing, maar het werkt.
Ad.
Post by Frédéric
je formule werkt zeker, Ad, maar indien ik na het invoegen van deze formule
toch nog iets wil schrijven in die bewuste cel, dan overschrijf ik steeds de
formule, waardoor ik dus slechts 1x de juiste opmaak bekom en na het
overschrijven de opmaak dus verlies, tenzij ik de formule dus steeds opnieuw
invoeg, wat echter een onbegonnen werk is.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /""zet hier je tekst";"")
Probeer hier eens iets mee.
Ad.
Post by Frédéric
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Roncancio
2005-01-06 23:19:01 UTC
Permalink
Deze macro lost als het goed je probleem op.

If Weekday([A1], vbMonday) > 5 Then
If Left([b1], 2) = " /" Then
[b1] = Mid([b1], 1)
Else
[b1] = " /" & [b1]
End If
Else
If Left([b1], 2) = " /" Then
[b1] = Mid([b1], 3)
End If

End If
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /"&"zet hier je tekst";"")
Deze gaat beter, als je op de cel dubbelklikt en je selecteerd "zet hier je
tekst"
kun je die gewoon wijzigen, de formule blijft heel.
Het is geen perfecte oplossing, maar het werkt.
Ad.
Post by Frédéric
je formule werkt zeker, Ad, maar indien ik na het invoegen van deze formule
toch nog iets wil schrijven in die bewuste cel, dan overschrijf ik steeds de
formule, waardoor ik dus slechts 1x de juiste opmaak bekom en na het
overschrijven de opmaak dus verlies, tenzij ik de formule dus steeds opnieuw
invoeg, wat echter een onbegonnen werk is.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /""zet hier je tekst";"")
Probeer hier eens iets mee.
Ad.
Post by Frédéric
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Frédéric
2005-01-07 19:37:04 UTC
Permalink
ik heb de macro uitgeprobeerd en hij werkt goed, het betekent nog wel dat ik
cel per cel moet toevoegen aan de macro: dit is een vrij groot werk waar ik
eerlijk gezegd wel tegenop zie, maar ik denk dat het nadien wel de moeite
loont.
ik kan zowel jou oplossing als die van Ad toepassen, allebei bedankt!
Post by Roncancio
Deze macro lost als het goed je probleem op.
If Weekday([A1], vbMonday) > 5 Then
If Left([b1], 2) = " /" Then
[b1] = Mid([b1], 1)
Else
[b1] = " /" & [b1]
End If
Else
If Left([b1], 2) = " /" Then
[b1] = Mid([b1], 3)
End If
End If
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /"&"zet hier je tekst";"")
Deze gaat beter, als je op de cel dubbelklikt en je selecteerd "zet hier je
tekst"
kun je die gewoon wijzigen, de formule blijft heel.
Het is geen perfecte oplossing, maar het werkt.
Ad.
Post by Frédéric
je formule werkt zeker, Ad, maar indien ik na het invoegen van deze formule
toch nog iets wil schrijven in die bewuste cel, dan overschrijf ik steeds de
formule, waardoor ik dus slechts 1x de juiste opmaak bekom en na het
overschrijven de opmaak dus verlies, tenzij ik de formule dus steeds opnieuw
invoeg, wat echter een onbegonnen werk is.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /""zet hier je tekst";"")
Probeer hier eens iets mee.
Ad.
Post by Frédéric
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Frédéric
2005-01-06 23:21:14 UTC
Permalink
Met jouw formule kan ik de gekozen cellen de juiste opmaak geven en inderdaad
achteraf toch nog een bijkomende waarde of tekst intypen, alleen zie ik het
mij nog niet doen, want het betekent dat ik dagelijks honderden cellen moet
overschrijven en eigenlijk gaat het dan nog steeds sneller door gewoon de
waarde zelf in de cel in te voegen die ik eigenlijk oorspronkelijk nodig had.
Toch help je mij met je formule, want die ik kan ik wél toepassen op andere
cellen die ik nadien helemaal niet meer moet overschrijven.
Thanks Ad, misschien valt er toch nog een wonderoplossing uit de lucht...
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /"&"zet hier je tekst";"")
Deze gaat beter, als je op de cel dubbelklikt en je selecteerd "zet hier je
tekst"
kun je die gewoon wijzigen, de formule blijft heel.
Het is geen perfecte oplossing, maar het werkt.
Ad.
Post by Frédéric
je formule werkt zeker, Ad, maar indien ik na het invoegen van deze formule
toch nog iets wil schrijven in die bewuste cel, dan overschrijf ik steeds de
formule, waardoor ik dus slechts 1x de juiste opmaak bekom en na het
overschrijven de opmaak dus verlies, tenzij ik de formule dus steeds opnieuw
invoeg, wat echter een onbegonnen werk is.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /""zet hier je tekst";"")
Probeer hier eens iets mee.
Ad.
Post by Frédéric
Dankjewel Ad, deze formule kan ik zeker toepassen, maar dan kan ik inderdaad
ik zou graag die bewuste opmaak willen én toch nog tekst of getallen kunnen
invullen. Toch bedankt voor je reactie.
Post by Ad Bécude
Frédéric,
=ALS(WEEKDAG(A1;2)>5;" /";"")
In dezelfde cel kun je nu volgens mij geen tekst meer zetten, je formule zal
verdwijnen.
Met v.w.opmaak kun je alleen maar iets met de opmaak van de cellen doen.
Ad.
Post by Frédéric
Indien in cel A1 de datum wordt weergegeven als een afkorting voor zaterdag
of zondag (dus door "za" of "zo"), dan laat ik in de voorwaardelijke opmaak
deze cellen 'groen' inkleuren.
Wat moet ik echter doen indien ik in cel B1 het teken " /" (dus: spatie en
dan gevolgd door het deelteken, enkel met de bedoeling om dit deelteken
visueel weer te geven) wil laten invullen, INDIEN in cel A1 inderdaad "za" of
"zo" wordt vermeld en dit teken niet wil weergeven bij vermelding van andere
dagafkortingen? De bedoeling is om de opmaak alzo weer te geven, maar ook
nog om andere gegevens in die bewuste cel te kunnen invullen.
Lees verder op narkive:
Loading...