(te oud om op te antwoorden)
som.als in combinatie met subtotaal??
bram
2004-08-04 17:43:50 UTC
Hallo,

wie helpt me uit de brand?

Waarom werkt het volgende niet:
=som.als(subtotaal(9;cb11:cb1390);"F";cy11:cy1390)

Excel moet binnen beriek CY11:CY1390 zoeken naar de letter F en de
daarbij
behorende getallen op dezelfde regel in kolom cb optellen.

Met som.als gaat dit prima.
Het vervelende is dat als ik de filters gebruik alleen het algemeen
totaal
zie en niet het subtotaal.
Als ik met het formulepalet de bovenstaande formule tover krijg ik
steeds
de melding dat ik help moet raadplegen voor veel voorkomende problemen
met formules.....


gr, Bram
Ingrid Baplue
2004-08-04 18:00:44 UTC
=SOM(SUBTOTAAL(3;VERSCHUIVING(CY11:CY1390;RIJ(CY11:CY1390)-MIN(RIJ(CY11:CY13
90));;1))*(CB11:CB1390="F")*(CY11:CY1390))

invoeren als matrixformule met [Ctrl]+[Shift]+[Enter]
--
Ingrid Baplue
Excel MVP
http://users.telenet.be/ingrid/excel/

Dit bericht is geplaatst in een nieuwsgroep. Post je evt antwoord of
vervolgvraag graag in de nieuwsgroep a.u.b.
Post by bram
Hallo,
wie helpt me uit de brand?
=som.als(subtotaal(9;cb11:cb1390);"F";cy11:cy1390)
Excel moet binnen beriek CY11:CY1390 zoeken naar de letter F en de
daarbij
behorende getallen op dezelfde regel in kolom cb optellen.
Met som.als gaat dit prima.
Het vervelende is dat als ik de filters gebruik alleen het algemeen
totaal
zie en niet het subtotaal.
Als ik met het formulepalet de bovenstaande formule tover krijg ik
steeds
de melding dat ik help moet raadplegen voor veel voorkomende problemen
met formules.....
gr, Bram
Johan Veninga
2004-08-05 13:53:01 UTC
Tja, of eenvoudiger:

Type de functie subtotaal één rij lager (dus met een lege rij):

Dus in cel CB1392 =SUBTOTAAL(9;CB11:CB1390).

Selecteer nu het bereik waarin je wilt filteren: CY11:CY1390 en kies voor AutoFilter.

Als je nu in je filter aangeeft: bevat "F", dan telt Excel uitsluitende de nog zichtbare, dus de niet gefilterde cellen op.

Vooral de blanco rij niet vergeten, want anders filtert Excel de telling ook keurig weg....
Post by Ingrid Baplue
=SOM(SUBTOTAAL(3;VERSCHUIVING(CY11:CY1390;RIJ(CY11:CY1390)-MIN(RIJ(CY11:CY13
90));;1))*(CB11:CB1390="F")*(CY11:CY1390))
invoeren als matrixformule met [Ctrl]+[Shift]+[Enter]
--
Ingrid Baplue
Excel MVP
http://users.telenet.be/ingrid/excel/
Dit bericht is geplaatst in een nieuwsgroep. Post je evt antwoord of
vervolgvraag graag in de nieuwsgroep a.u.b.
Post by bram
Hallo,
wie helpt me uit de brand?
=som.als(subtotaal(9;cb11:cb1390);"F";cy11:cy1390)
Excel moet binnen beriek CY11:CY1390 zoeken naar de letter F en de
daarbij
behorende getallen op dezelfde regel in kolom cb optellen.
Met som.als gaat dit prima.
Het vervelende is dat als ik de filters gebruik alleen het algemeen
totaal
zie en niet het subtotaal.
Als ik met het formulepalet de bovenstaande formule tover krijg ik
steeds
de melding dat ik help moet raadplegen voor veel voorkomende problemen
met formules.....
gr, Bram
bram
2004-08-05 16:56:59 UTC
Post by Ingrid Baplue
=SOM(SUBTOTAAL(3;VERSCHUIVING(CY11:CY1390;RIJ(CY11:CY1390)-MIN(RIJ(CY11:CY13
90));;1))*(CB11:CB1390="F")*(CY11:CY1390))
invoeren als matrixformule met [Ctrl]+[Shift]+[Enter]
--
Ingrid Baplue
Excel MVP
http://users.telenet.be/ingrid/excel/
Dit bericht is geplaatst in een nieuwsgroep. Post je evt antwoord of
vervolgvraag graag in de nieuwsgroep a.u.b.
Post by bram
Hallo,
wie helpt me uit de brand?
=som.als(subtotaal(9;cb11:cb1390);"F";cy11:cy1390)
Excel moet binnen beriek CY11:CY1390 zoeken naar de letter F en de
daarbij
behorende getallen op dezelfde regel in kolom cb optellen.
Met som.als gaat dit prima.
Het vervelende is dat als ik de filters gebruik alleen het algemeen
totaal
zie en niet het subtotaal.
Als ik met het formulepalet de bovenstaande formule tover krijg ik
steeds
de melding dat ik help moet raadplegen voor veel voorkomende problemen
met formules.....
gr, Bram
Ingrid,

dit is echt niet meer normaal.

HET WERKT !!!!

ik begrijp er niets van maar mijn vreugde is des te groter!

Drieduizend maal dank alvast!!!

gr, Bram

btw: per ongeluk twee keer dezelfde posting gedaan. sorry....